Client Notification about Older Browsers

In order to maintain the highest levels of data security, we will no longer support the security protocol TLS 1.0 after June 25, 2018.

This means that if you are using an older web browser, you may not be able to load our website or account management tools. This change is mandated by the PCI (Payment Card Industry) Security Council and affects all merchants and service providers that transmit credit card data.

You Likely Won’t Be Affected

We anticipate this change will impact only 4% of users – those using older phones and computers to access our online tools.

Minimum Requirement

Below is a list of browser versions that will be supported after the June 25.

  • Google Chrome: 44 and above
  • Firefox: 38.1 and above
  • Internet Explorer: 11
  • Edge: 12 and above
  • Opera: 30 and above
  • Safari: 9 and above
  • Safari Mobil: 8 and above
  • Android OS Browser 5.1 and above

To maintain access to InCharge.org and your I’m InCharge, please update your browser if it falls below the above versions.

What Do I Do to Maintain Access

Check your browser. If you are accessing our website and I’m InCharge with a version listed above, no action is required. You will not be impacted by this change.

If you are accessing our website from an older version than listed above, update your device’s software.